Degraded Performance

Incident Report for Clearstory

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 17:05 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 24, 2025 - 16:19 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 14:45 PDT

Identified

We have identified and are currently working a solution for degraded performance in certain areas of the application that impacts adjusting user permissions/emails on projects as well as retrieving recipients for T&M Tag signature requests.
Posted Apr 24, 2025 - 08:31 PDT
This incident affected: Core API.